Updating FreeBSD 6.x
Before you start
Setup environment for packages:
setenv PACKAGESITE ftp://ftp2.us.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/Latest/
Using freebsd-update to update standard kernels
1) Add freebsd update package:
pkg_add -r freebsd-update
2) Setup and use freebsd-update:
cp /usr/local/etc/freebsd-update.conf.sample /usr/local/etc/freebsd-update.conf
mkdir /usr/local/freebsd-update
freebsd-update fetch
freebsd-update install
shutdown -r now
Updating packages and ports
1) install portaudit package
pkg_add -r portaudit
rehash
2) Check for updates
/usr/local/sbin/portaudit -Fda
3) Updating of Ports tree
pkg_add -r portsnap (bundled with 6.x)
portsnap fetch
portsnap extract (only have to do this once on a new install)
portsnap update
4) Updating Applications
pkg_add -r portupgrade
rehash
portversion -v -l “<" portupgrade -varRPP (tells it to be verbose, act on up and down depends, and upgrade only with packages)
on any that fail then do portupgrade -varR (this tells it to build from ports)